SSL certificate renewals are very slow or failing

Incident Report for Awwwsome

Resolved

This incident has been resolved.
Posted Mar 28, 2021 - 03:44 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2021 - 03:24 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 28, 2021 - 01:51 CET

Investigating

We are aware of the ongoing problem affecting SSL certs renewals. The process is either super-slow or failing, which may result in making your site inaccessible. An "Insecure site" error may be displayed by the browsers.

We're on it!
Posted Mar 28, 2021 - 01:44 CET
This incident affected: Cloud Hosting Platform.