Performance Monitoring indicates extended loading times for sites secured with Cloudflare
Incident Report for Awwwsome
Resolved
This incident has been resolved.
Posted Apr 05, 2021 - 21:09 CEST
Update
We are still investigating this issue with external providers.
Posted Mar 31, 2021 - 22:57 CEST
Investigating
We are aware of the issue affecting our Performance Monitoring.

The sites secured with Cloudflare are reporting extended loading times (even 15+ seconds) in the synthetic checks. We identified the root cause — some CSS and JS assets are getting the 522 error from Cloudflare. It suggests that Cloudflare doesn't have these files stored in the cache and, therefore, reports an error.

At the same time, the real-life performance is not affected. Both GTMetrix and WebPageTest are reporting optimal loading times (the maximum of fewer than 4 seconds).

We are working with the Cloud Hosting engineering team, Cloudflare, and Site24x7 (Performance Monitoring provider) to find the root cause and develop the fix. As of now, the ETA for the fix is unknown.

We will post more updates on this issue soon!
Posted Mar 31, 2021 - 12:07 CEST
This incident affected: Apps & Services (Performance Monitoring).